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Pathway Building in Pathway Studio Web 11.1 

 

Introduction to Pathway Building Tools in Pathway Studio Web 11.1 

The newly designed Pathway Studio Web 11.1 makes pathway building faster, easier and more intuitive. 

The interface provides a simple path to build and filter pathways, providing powerful easy-to-use 

filtering tools and short cuts, designed to satisfy the novice user while still maintaining advanced filter 

options for the expert user.   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

Start your network building activities 
from the new Network Builder 
interface. 

 

Shortcut menu options allow for quick 
visualization of network results from 
preset menus. 

 

Advanced network building tools allow 
the expert user to apply specific entity 
and relation filters for more focused and 
specific results. 

 

The Interactive Network Builder is 
simple-to-use interface for filtering 
larger networks to produce smaller, 
more manageable and focused results. 
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In addition, Pathway Studio Web 11.1 also includes detailed step-by-step instructions for advanced 
pathway building for many of the most commonly used workflows.  The “How Do I…” section organizes 
information based on biological and molecular categories.  Access the “How Do I…” section from the 
lower left pane. 

 

Next, select an area of interest from the drop-down menu. 

 

The “How Do I…” section provides 
detailed step-by-step instructions for 
some of the more commonly used 
pathway building workflows. 
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Finally, select a specific workflow from the options provided. Once selected, the detailed instructions for 
building this pathway (using the Advanced Pathway Tool provided in the Network Builder) are provided 
on screen.  For ease-of-use you can select to view the step-by-step instructions in a new window.  See  
more description about the Advanced Pathway Tool later in this document. 

 

 

 

 

 

 

 

 

 

Note:  Not all workflows are possible for all database types.  For example, subscribers of the Mammal 

only database cannot examine networks that include relations between small molecules and diseases or 

cell processes as this data is only included in the ChemEffect® dataset. Subscribers to the Plant 

database could not, for example, see associations with Clinical Trials, as this is associated only with 

mammalian data and included in the DiseaseFx® dataset. 

  

The detailed workflows provided allow 
you to quickly and easily find answers 
to your biological questions. 
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Now, let’s take a closer step-by-step look at both basic and advanced network building workflows. 
 

Shortcut (Basic) Workflows for Network Building 

 
The both the shortcut (basic) menus and the advanced pathway building tools can be accessed from the 
Network Builder dialog.  With a pathway view open, select the desired entity/entities to start.  Go to 
the Add menu and select “Network Builder.” 
 

 
In the Network Builder dialog, first select the type of network you want to build from the Tool Category 
drop-down menu in Step 1. 

 

 

 

 

 

 
 

 
 
 
 
 
 
 

In Step 1, the tool definitions are as follows: 
 

 Direct Interactions: find relationships between two or more selected entities 
 Shortest Path for a Pair of Entities: find relationships between two selected entities, adding 

entities as needed to form the relationships 
 Expand Pathway: find entities in the database directly connected to the entity /entities 

selected 

 Common Targets: find one or more downstream targets that are regulated by at least two or 
more of the selected entities 

 Common Regulators: find one or more upstream regulators that regulate two or more of the 
selected entities 
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Once the desired build pathway algorithm is selected in Step 1, the One-Step Shortcuts menu directly 
below lists options that are available for that algorithm.  Chose the desired shortcut and then selet 
“Next.” 

 

 

 

 

 

 

 

 

 

Next the Step 5 Setup Preview dialog appears.  This displays the applied entity and relation filters, each 
followed by a red “x.”  If you want to further refine your network at this point by removing an entity or 
relation category, select the “x” to remove that category.   [Note: once removed, the only way to add 
the entity or relation type back is to start your network building workflow from the beginning.] 

 

At this point you can select “Finish” to see the resultant network.   

Alternatively, you can select “Launch Interactive Network Builder.”  This will allow you to see statistics of 
your network for entities and relations.  It will allow you to filter your network by entity type, relation 
type, relation effect (positive, negative, unknown) and by the reference count for the relations.   

Shortcut preset menu 
options allow you to build 
your network quickly 

Appendix One lists definitions of 
of each shortcut option, including 
entity and relation selection, 
directionality and minimum limits 
(if applicable). 
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The Interactive Network Builder is a powerful easy-to-use dialog to facilitate reducing larger 
networks to smaller more precise results. 

 

 

 

 

 

 

 

 

 

 

 
Note:  If the network is larger than 200 entities, the graph view will not display on the right.  Instead 
the Entity Table View will display.  The checkbox filters on the left are still available. 

In the example below, the Functional Class entity type was deselected (uncheck box).  This removes the 
functional class entities from the resultant network. 
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After using the Interactive Network Builder to apply the desired filters, select the “Finish” button to see 
the resultant network.  If your network is still large and you would like to apply additional filters, you 
can access the Interactive Network Builder again by selecting Filters > Basic from the graph view. 
 

 

 

Network results can always be viewed in tabular form by selecting either Entity Table View or Relation 
Table View from the View menu. 
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Advanced Network Building Tools for Expert Users:  Building Focused Networks 

Pathway Studio Web 11.1 retains advanced pathway building tools that allow expert users to define very 
specific networks through advanced filtering options, utilizing relation subtype categories and other 
specific entity and relation properties fields.  Filtering steps can be applied during the network building 
process or after the initial network has been completed. 

Similar to the shortcut (basic) workflows, advanced workflows are accessed through the Network Builder 
in the Add menu. 

 

In Step 1 of the Network Builder dialog, select the desired network type from the drop-down menu.  
Then select “Advanced Pathway Tool” in the Advanced box.  Finally, chose “Next.” 

 

Advanced network building tools 
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In Step 1, the tool definitions are as follows: 
 

 Direct Interactions: find relationships between two or more selected entities 
 Shortest Path for a Pair of Entities: find relationships between two selected entities, adding 

entities as needed to form the relationships 
 Expand Pathway: find entities in the database directly connected to the entity /entities 

selected 
 Common Targets: find one or more downstream targets that are regulated by at least two or 

more of the selected entities 
 Common Regulators: find one or more upstream regulators that regulate two or more of the 

selected entities 

 

In Step 2, select the desired directionality of the relations.  For some algorithms, such as Common 
Targets, or Common Regulators, the directionality is already defined.  If in doubt of the directionality of 
a specific relation type, select “All” at this step.  For most applications keep the # of Expansion Steps at 
1.   Select “Next.” 

 

 

 

Next, select the entity type(s) and relation type(s) to include in the network.  See Appendix Two for 
definitions of each entity and relation type.  The entity and relation types displayed in this view will be 
dependent upon your individual Pathway Studio subscription. 

When an entity or relation is selected, the “Add Conditions” options becomes available which allows for 
filtering based on specific properties of that entity or relation. 
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To apply advanced filtering on properties data for an entity or relation, click on “Add Conditions.”  The 
advanced filtering dialog will appear.  Select the properties field and the desired filtering paremeter(s).  
In the example below, the applied filter will identify only Biomarker relations that have a property 
“Biomarker Type” of “prognostic.” 

Note:  Filtering on specific properties can be applied during network building, or later, after a network 
has been completed. 

 

 

Next, select the source of entity and relation data for network building, either from the entire database 
(more common), or from a designated saved pathway/group.  Then select, “Next.” 
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The Setup Preview step provides an additional opportunity to reduce the size of your network by 
removing a entity or relation type(s).  Total number of entities and relations are summarized and the 
types included are listed.  A specific entity or relation type can be removed by selecting the red “x.”  .   
[Note: once removed, the only way to add the entity or relation type back is to start your network 
building workflow from the beginning.] 

 

Select “Finish” to see your resulting network. 
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Alternatively, in Step 5 Setup Preview, you can select “Launch Interactive Network Builder.”  This will 
allow you to see statistics of your network for entities and relations.  It will allow you to filter your 
network by entity type, relation type, relation effect (positive, negative, unknown) and by the reference 
count for the relations.  The Interactive Network Builder is a powerful easy-to-use dialog to 
facilitate reducing larger networks to smaller more precise results.   

In the Interactive Network Builder example shown in the following two figures a relation reference count 
filter of ≥ 5 references is applied to a network 
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By moving the scroll bar for # of References to five, only relations with a reference of five or above 
remain. 

 

Select “Finish” to view the resultant network in the graph view. 

 

 

 

The confidence level of 
the network is 
increased by including 
only relations with 
higher numbers of 
literature references. 
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Once a network is completed, additional subtractive filters can be applied to reduce the network to more 
specific results.  Alternatively, a subset of the network can be selected for further analysis. 
 
Subtractive Filter - Basic 
To apply a subtractive filter to a network, in the graph view select Filter > Basic. 
 

 
 
This will open the Interactive Network Builder.  From here you can select to remove any entity or 
relation type, remove relations based on effect (positive, negative, or unknown), or filter relations based 
on the number of literature references.  Simply uncheck the box to remove a specific category, or move 
the scroll bar to set the threshold for references for all relation. 
 

 
 
When done, select the “Finish” button to see the resultant network. 
 
 
Subtractive Filter - Advanced 
To apply subtractive filters based on properties data, in the graph view select Filter > Advanced. 
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This will open the list of entities and relations included in the network.  Select “Add Condition” to open 
the properties filter. 
 

 
 
In this example, the properties filters identifies Regulation relations with a positive effect.  By applying 
this filter, all Regulation relations that are NOT positive (in other words, negative or unknown Regulation 
relations) will be removed from the network. 
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Selection Filters 
 
To apply a positive selection to a network to go the Select menu and chose “Advanced.”  The advanced 
properties filter will appear. 
 
 

 
 
Use the Select Advanced menu to identify desired properties data.  In the instance shown below, this 
search will identify relations with supportive sentences that contain the word “neuron.”  Select “Search.” 
 

 
 
The relations that have supportive sentences in their references that contain the key word are 
highlighted in blue.  
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Once the selection has been made, you can copy the highlighted relations into a new graph view for 
further analysis. 

 

 

 

 

 

 

 

 

 

 

 

If you have any questions about Pathway Studio Web 11.1 contact Customer Care.  

http://help.elsevier.com/app/ask_aer/p/9047/session/L3RpbWUvMTQ0NzY5MDA5OS9zaWQvVWdVdCpFQm0%3D
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Appendix One:  Pathway building shortcut definitions. 

Category 
Sub-
Category 

Relationship(s) Entity(ies) Direction 
Minimum 
Limits 

Neighbors from 
DB Expression 

Targets 

Expression, 
PromoterBinding, 
miRNAEffect 

Proteins, Complexes, 
Functional Classes 

Downstream NA 

 
Expression 
Regulators 

Expression, 
PromoterBinding, 
miRNAEffect 

Proteins, Complexes, 
Functional Classes, small 
molecules  

Upstream NA 

 
Physical 
Interactions 

DirectRegulation, Binding 
Proteins, Complexes, 
Functional Classes, small 
molecules  

All NA 

 

Protein 
Modification 
Targets 

ProtModification 
Proteins, Complexes, 
Functional Classes  

Downstream NA 

 

Protein 
Modification 
Enzymes 

ProtModification 
Proteins, Complexes, 
Functional Classes   

Upstream NA 

 
Diseases 

Biomarker, ClinicalTrial, 
GeneticChange, 
QuantitiveChange, 
Regulation, StateChange 

Diseases All NA 

 
Cell Processes ClinicalTrials, Regulation Cell Processes Downstream NA 

  All All All All NA 

Direct 
Interactions 

Physical 
Interactions 

DirectRegulation, Binding 
Proteins, Complexes, 
Functional Classes  

All NA 

 
Expression 
Regulation 

Expression, 
PromoterBinding, 
miRNAEffect 

Proteins, Complexes, 
Functional Classes  

All NA 

 
Protein 
Modification 

ProtModification  
Proteins, Complexes, 
Functional Classes   

All NA 

  All All All All NA 

Shortest Path Physical 
Interactions 

DirectRegulation, Binding 
Proteins, Complexes, 
Functional Classes  

All NA 

 
Expression 
Regulation 

Expression, 
PromoterBinding, 
miRNAEffect 

Proteins, Complexes, 
Functional Classes 

All NA 

 
Protein 
Modification 

ProtModification 
Proteins, Complexes, 
Functional Classes   

All NA 

  All 

DirectRegulation, Binding, 
Expression, 
PromoterBinding, 
miRNAEffect, 
ProtModification,  
Chemical Reaction, 
MolSythesis, MolTransport 

Proteins, Complexes, 
Functional Classes, small 
molecule 

All NA 

Common 
Targets Expression 

Targets 

Expression, 
PromoterBinding, 
miRNAEffect 

Proteins, Complexes, 
Functional Classes 

Downstream 2 

 
Physical 
Interactions 

DirectRegulation, Binding 
Proteins, Complexes, 
Functional Classes  

Downstream 2 

 

Protein 
Modification 
Targets 

ProtModification  
Proteins, Complexes, 
Functional Classes  

Downstream 2 
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Common 
Diseases 

Regulation, Clinical Trial Diseases Downstream 2 

 
Common Cell 
Processes 

Regulation, Clinical Trial Cell Processes Downstream 2 

  All All All Downstream 2 

Common 
Regulators Expression 

Regulators 

Expression, 
PromoterBinding, 
miRNAEffect 

Proteins, Complexes, 
Functional Classes  

Upstream 2 

 
Physical 
Interactions 

DirectRegulation, Binding  
Proteins, Complexes, 
Functional Classes  

Upstream 2 

 

Protein 
Modification 
Enzymes 

ProtModification 
Proteins, Complexes, 
Functional Classes  

Upstream 2 

 

Common 
Diseases 

Biomarker, 
GeneticChange, 
QuantitiveChange, 
Regulation, StateChange 

Diseases Upstream 2 

 

All All All Upstream 2 
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Appendix Two:  Entity and Relation Definitions. 
 
ENTITIES:  

Cell – mammal cell types, including immunology subtypes     
(mammal+ChemEffect+DiseaseFx+CellEffect only) 

Cell Process * – biological processes, most coincide with Gene Ontology. 

Clinical Parameter – measured parameters of the human body used in clinical practice (mammal and 
mammal+CE+DFx only). 

Complex * – several polypeptides that form a complex via physical interactions. 

Disease – Mammal: health conditions and disease terms from MeSH; plant: Plant diseases. 

Functional Class * – most functional classes coincide with Gene Ontology. 

Protein – defined by Entrez Gene - represents both genes and the gene products, including proteins 
and miRNAs. 

Small Molecule – Mammal: naturally occurring metabolites and small molecules found in cells; 
ChemEffect® adds drugs (including some biologically active polypeptides that work as drugs such as 
monoclonal antibodies) and nonnaturally occurring small molecules to the mammal database. Plant: 
naturally occurring metabolites and small molecules and other plant related chemicals (ex. herbicides or 
research related chemicals). 

Treatment – non-chemical treatments and environmental conditions, such as cold shock. 

*Container Entities – these are valid entities but also can have proteins mapped to them. You can see 
the proteins for the container entities in the “child concepts” in the property records for the specific 
entity. 

 

RELATIONS: 

(Mammal and Plant): 

Binding - direct physical interaction between two molecules. 

ChemicalReaction - enzyme catalyzed reaction involving small molecules. 

DirectRegulation - influences target activity by direct physical interaction (excluding promoter binding 
interactions). 

Expression - regulator changes protein abundance by affecting levels of transcript or protein stability. 
miRNAEffect the inhibitory effect of a miRNA on its mRNA target. 

Regulation - changes the activity of the target by an unknown mechanism (may be direct or indirect). 
This is a less specific relation type than others provided. 

MolSynthesis - regulator changes the concentrations of the target (usually a small molecule target). 

MolTransport - regulator changes the localization of the target (molecular translocation, export, import 
etc.). 

PromoterBinding - regulator binds to the promoter of a gene. 

ProtModification - regulator changes the modification of the target molecule, usually by a direct 
interaction.  

Filtering Field Name: Mechanism; Sub-Categories: acetylation, cleavage, deacetylation, 
demethylation, dephosphorylation, direct interaction, methylation, phosphorylation, 
posttrascriptional inhibition, proteolysis, ubiquitination. 
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(Mammal + ChemEffect+DiseaseFx + CellExpress – in addition to relations listed above): 

CellExpression - proteins expressed in a particular cell type 
Filtering Field Name: Mechanism; Sub-catgory: surface (or null)  

Quantitative Change - Changes in abundance/activity/expression of a gene/protein/small molecule in 
a disease state (between disease-protein/complex/functional class/small molecules).  

Filtering Field name: Quantitative Type; Sub-Categories: Expression, Abundance, Activity, 
Secretion 

Genetic Change - Genetic changes in a gene in a disease state such as gene deletions, amplifications, 
mutations or epigenetic changes (between diseaseprotein/complex/functional class).  

Filtering Field Name: Change Type; Sub-Categories: Gene Deletion, Mutation, Gene 
Amplification, Epigenic methylation 

Biomarkers - Identification of proteins/complexes/functional classes/metabolites that are prognostic or 
diagnostic biomarkers for a disease (between diseaseprotein/complex/functional class/naturally 
occurring small molecules).  

Filtering Field Name: Biomarker Type; Sub-Categories: Diagnostic, Prognostic 

State Change - Changes in a protein’s posttranslational modification status or alternative splicing 
events associated with a disease (between diseaseprotein/ complex/functional class).  

Filtering Field Name: Change Type; Sub-Categories: Alternate Splicing, Phosphorylation 

Functional Association - Different types of functional associations between a disease and a cellular 
process or another disease (between Disease – Cell Process) (no sub-types). 

Clinical Trials - Disease/cell process relation representing clinical trials conducted for a drug against a 
disease (from ClinicalTrials.gov) (between Disease/Cell Process – Small Molecule) (no sub-types). 

 

 

 

 

 

 

 

 

 

 


